+1
Answered

The PDF file cannot be found in Ad Hoc build

mgruberdesign 8 years ago updated by icahill (Administrator) 8 years ago 5
When I create an Ad-Hoc build, the PDF file is not loading, and I get an error message as follows:

Error
The file 'GlobalThinkTanks2011.pdf' cannot be found.

Why would the PDF not be included in the build?

Do I have to tell it to include the PDF?
Is your PDF pathed correctly? If it is stored in a folder in the CMS, your WIRE needs to reflect that.

source=documents/pdf.pdf
Yes, it is sourced correctly.

documents/GlobalThinkTanks2011.pdf

pdf name="mag" alias="MAG" source="documents/GlobalThinkTanks2011.pdf" height="100%" width="100%" align="left" valign="top" spreads="no" covertile="no" weblinkclass="weblink" pagelinkclass="pagelink"

It works fine in the Fusebox test.

App ID is 874
Have you tried killing the Ad-Hoc from the background of the device and trying it again?

I just tested your WIRE code and your PDF on my own Ad-Hoc build and it works fine.
I have tried multiple times to replace rebuild and replace the AdHoc on my iPad.

I am on a mac using Chrome, Firefox, and Safari. All attempts end in the same result, it cannot find the PDF file, yet it works fine in Fusebox.

Any ideas?
There may be an issue with the way the PDF was encoded (Quartz PDFContext). Not entirely sure, but replacing it with a new PDF seems to have solved the issue.