+1
Under review

Fusebox not compatible with my Android device

dinglezos 7 років тому оновлено icahill (Administrator) 7 років тому 1
I am trying to install Fusebox but is not compatible with my device. I use Android 4.1.1
Can you please give me a little more information on the device you are using? What type of phone or tablet is it?

Currently fusebox is set to support over 1800 different devices, but there are still some out there that might not allow you to download. If you can tell us which device you are using we may be able to add it to our support list.

Thanks.