+1
Under review

Using videocontrol seekto

jralston 8 years ago updated 8 years ago 21
I just set a seekto value of 72 on my videocontrol element and it starts playing at 1:17 instead of 1:12.

Is it always off by 5 seconds?
setting seekto to 71 is starting the video at 1:06.
I will take a look to see if I can replicate the issue and log a bug if so. Thanks for bringing it to my attention.
What file format are you using for your video file?
.mp4

Do you want me to add you to the project?
Yeah that would be great. I am not able to replicate it here. Add icahill@rarewire.com to the project.

Thanks.
Done. It is the project called "interactive MOA"

If you wouldn't mind, please just make a copy as I am currently working on this project.

I'm sure you can tell based on all my video questions today. :)
I am not sure what is happening. I have not been able to replicate this issue with any other video but yours. Oddly, if you set the seekto to 30 secs or even 77 secs it seems to respond just fine. I am wondering if there is a glitch in your .mp4 around the 72 sec mark that is causing some error.

I will have someone else take a look and get back to you.
Do you know what framerate this video is in?
It looks like it is in AVC encoding and I think that might be causing the hiccup. Can you reformat it to H.264 maybe?
the framerate is normal, 29.97
It looks like it's already using H.264
that is weird, my quicktime says it isn't. hm. I will continue to look into this.
Just an update. We are still looking into the cause of this issue and should have it resolved soon.
I'm also supposed to get a new video today with a different aspect ratio. So maybe the new one will work better.
I just uploaded the new video and I'm experiencing the same problem with both of my videoconrol actions using seekto. Neither one starts the video at the time I intend.
Alright,

I am going to escalate this bug within the company.

Thanks.
There might be a chance that you are mistakenly encoding your video in a video stream or on demand format? I only say this because it does appear that the system is rendering start time based off some segment boundary, which is why it is launching a few seconds away from your intended target.

This is taken directly from Apple documentation:

initialPlaybackTime
The time, specified in seconds within the video timeline, when playback should start.

@property (nonatomic) NSTimeInterval initialPlaybackTime

Discussion
For progressively downloaded content, playback starts at the closest key frame prior to the provided time. For video-on-demand content, playback starts at the nearest segment boundary to the provided time. For live video streams, the playback start time is measured from the start of the current playlist and is rounded to the nearest segment boundary.
The default value of this property is -1, which indicates the natural start time of the movie.
I added a m4v file of your video to the project and named it "test" it seems to respond to the seekto attribute. The major difference that I made, was to change the bit rate one that is less than 500. I think this over rode any potential streaming format that Sorenson Squeeze uses.
I'm sorry for not getting to this sooner, but I just tried this out and it is still not starting at the point I specify even using your m4v file.