+1
Declined

App Rejected for 3rd Gen iPads

pulseblue 8 years ago updated by icahill (Administrator) 8 years ago 18
Hi there,

I attempted to submit one of my apps, but got rejected for this reason:

"We found that your app exhibited one or more bugs, when reviewed on iPad (3rd Gen) running iOS 5.1.1, on both Wi-Fi and cellular networks, which is not in compliance with the App Store Review Guidelines.

Your app launches to a black screen and none of the content is accessible. "

Any ideas why?

I just noticed a dropdown on the Platform Settings page that says "Rarewire Engine Version". Should I be selecting the latest version, or using the defaulr one?

Thanks!
Lets try and get to the bottom of this.

Did you create this App as a universal App in your studio settings?

Are you using platform tags? We have seen this issue with an incorrect platform tag before.

I am assuming you created and tested with an Ad-Hoc build before you submitted this?
Yes I created this as a Universal App

Not sure what you mean by Platform tags, but I don't think I'm using them

I only tested this with Conduit, not with Ad-Hoc. Not really sure how to test with Ad-Hoc...
You create an Ad-Hoc build by navigating to the build section and creating an IPA using an Ad-Hoc provisioning profile and your existing p12 file. Make sure you add your device UDID to the provisioning profile.

I would start by changing your wire version to 1.2 and then test by installing an Ad-Hoc build. If that doesn't fix the issue let me know and we can try a few other things.
I found this cert stuff pretty confusing!

Am I doing this right?

On developer.apple.com, I go to iOS Provisioning Portal

Provisioning > Distribution > Edit {App Distribution Provisioning Profile}, Select Distribution Method: AdHoc, then Select relevant devices, and Submit. Then Download the profile.

On Rarewire:

Go to Build > Create Ad-Hoc, then on right hand side, Under 'Distribution Provisioning Profile', choose 'Select Certificate', then replace certificate. Once that is done, select, 'Ad-Hoc Build' radio button, then 'Build Ad-Hoc' button.

In Build > Build Logs, I now get a 'failed' build

Obviously I've done something wrong here, but what?
Unfortunately Apple doesn't make it easy on us do they? We have made it as easy as possible to use our system, if only Apple would simplify their process.

You will need to make very certain that the provisioning profile you are generating exactly matches the distribution certificate you used to create your p12. I most cases I suggest revoking and deleting your old provisioning profiles and creating a new one to ensure that it matches the cert you already have.

The portion you are doing in RareWire is correct, you can upload the same p12 as your cert, but the profile needs to be an ad-hoc that matches.
Thanks for your help Ian, no Apple definitely don't make it easy!

I've deleted and recreated my certificates a few times now. Still doing something wrong it seems...

Am I right in thinking I can use the same .p12 certificate for both adhoc and app store certificates?

Once I've created my .p12 file, I go to Provisioning > Distribution Provisioning Profiles and create two new profiles, one with AdHoc selected, and one with AppStore selected

So I have 3 files:

App_certificate.p12
App_adhoc.mobileprovision
App_appstore.mobileprovision

Back in Rarewire, on the Settings page, I load up App_certificate.p12 and App_appstore.mobileprovision

On the Build > Create Adhoc page, I load up App_certificate.p12 and App_adhoc.mobileprovision

Still getting a Failed message when I try to build so I must be doing something wrong...
You should be able to reuse your .p12 for both provisioning profiles.

You need to make sure your .p12 was created using a distribution cert without a wildcard and that your provisioning profiles are associated with that same Cert. Have you seen the video we created to walk through this process?

The only difference between the ad-hoc and the release provisioning profiles is the one radio button setting it as ad-hoc.

You are certainly uploading them correctly, it must be the files are not lining up.
It looks like there is a small build error on our side based on a push we did last night. If you hover over the word "Failed" in the build logs, what error displays in the tool tip?
The first few say failed_scp_content

But the later ones, after I refreshed all the certificates, all say failed_xcode_build
Alright, the first error you mention had to do with the error on our side.

The other error (failed_xcode_build) looks like something on your end. This means the system failed to build the xcode project with code signing - there could be a number of issues here. Generally this means you have a bad bundle identifier or a bad mobile provisioning profile.

Please make sure that you have presented your App Bundle ID in the studio correctly, this should be the Bundle ID search string and not the bundle seed ID.

See more info here: http://developer.apple.com/library/io...

Also make sure that the provisioning profile was built with the App ID that matches the distribution cert and the studio.
Yes, I built the app using only the Bundle ID (ie not the bundle seed ID too). And the provisioning profiles are using that very same bundle ID

Still no luck in building...anything else it could be?
Well these things can be very particular. Without seeing your Apple Developer account, it could be something very minor. Generally though it is best practice to create your p12 with provisioning profiles for both ad-hoc and release all at once and upload it all to the studio. This helps make sure that they all line up correctly.

Given that you were able to create a p12 and provisioning profile once and submitted to Apple, I would probably suggest that you start the process over and generate a new p12 with provisioning profiles for both your Ad-Hoc and Release at the same time. Upload them all to the Studio in the appropriate places. Once the Ad-Hoc build is generated and tested (fixing this black screen issue), then you can generate your IPA for the new release build.
Any luck on getting your Apple certs working?
not yet :-/

I've recreated my certs a number of times (at the same time) and also tried changing the bundle ID then recreating the certs, but still no luck.

I'll have a few more tries this weekend, hopefully will work it out!
If you are still having issues, you may consider emailing me and sharing your apple login credentials, maybe I will be able to go in there and see what you are doing wrong.
Sure, whats your email address?
Hi Ian, yes, I'm happy to give you access - what's your email address?

Any help much appreciated!!