+3
Answered

salesforce connection from sample file.

jchristman 7 years ago updated by icahill (Administrator) 7 years ago 5
Rarewire training class. - sample salesforce script using standard sdk. Is there a walk through available on the complete setup on the rarewire side of it. Also the sample script I tried to reuse and connect to my dev org and I am getting an error about invalid datasource salesforce for tag with name list. So I am not sure I got the setup correct or if I copied something wrong. any help would be apprciated.
We'll work on getting a standard SDK walkthrough together for the community today.

The invalid datasource error is due to an incorrect Application Key on the Salesforce side, which we'll resolve with the walkthrough.

Thanks for attending!
@jchristman

Here is a walkthrough on how to setup SalesForce and get your API keys. Included is a sample wire to test the integration. 

https://studio.rarewire.com/wordpress/2013/10/intro-to-salesforce-integration/">https://studio.rarewire.com/wordpress/2013/10/intro-to-salesforce-integration/

Let us know if you have any questions.
The app I am testing from is: 6858

I used my original salesforce account, even tried creating a new account; I can't get the salesforce login to pop-up using the example from the class.

I have gone through the integration blog entry from above

I have the salesforce consumer key and call back in my salesforce rarewire sdk settings.

Not sure what the best, next step should be. I am at the Hackathon this weekend. Any help is appreciated :)
Steve, looks like your engine version in the studio is 1.4. You need to bump that up to 1.5.2 to get access to SalesForce and make sure to have the latest Fusebox build on your device.

Please feel free to email me directly during the hackathon! ajones@rarewire.com
A note for others playing with Salesforce SDK with WIRE.

It appears fusebox is latching on to your SDK settings the first time they are inputted. Resulting in errors if a key is inputed incorrectly or a URI is not matched. The best way to remove this issue is to wipe your SF app from fusebox (swipe left on your app name) and delete, then snapshot and download it fresh from within fusebox.

We also recommend that you select "Full Access" from the API Setting pane within your Salesforce account for the app. We will correct the documentation linked above to avoid any confusion.