+1
Answered

Trouble with classes

Lcdrgreg 7 years ago updated 7 years ago 2
Why isnt the home panel and its objects being created on startup, kicking my butt.

<wire>
<classes>
<class name="basicblock">
<panel name="[param:blockname]" alias="[param:BLOCKALIAS]" width="25%" height="33.4%" xpos="[param:blockxpos]" ypos="[param:blockypos]" background="[param:blockbackground]" onclickup="[param:openbioblock]" cornerradius="17"/>
</class>
<class name="basicbio" alias="BASICBIO">
<panel name="[param:biobio]" alias="[param:bioalias]" width="50%" height="100%" background="#FFFFFF"/>
<panel name="[param:biovideo]" alias="[param:biovideoalias]" width="50%" height="50%" xpos="50%" background="#000000"/>
<panel name="[param:bioimage]" alias="[param:bioimagealias]" width="50%" height="50%" xpos="50%" ypos="50%" background="#999999" onclickup="deletetest"/>
</class>
<class name="home">
<panel name="home" alias="HOME" width="100%" height="100%" background="#00ff00">
</panel>
</class>

</classes>
<main>
<panel name="background" alias="BACKGROUND" width="100%" height="100%" background="#ffffff" />
<panel name="basic" width="100%" height="100%" alias="BIOPAGEPANEL"/>

</main>
<actions>
<action name="start" onit="yes">
<play action="createhome"/>
</action>

<action name="createhome">
<sync>
<create class="home" target="BACKGROUND"/>
<create class="basicblock" blockname="redpanel" blockalias="REDPANEL" blockxpos="0" blockypos="0" blockbackground="FF0000" openbioblock="createbiopageone" target="home"/>
<create class="basicblock" blockname="orangepanel" blockalias="ORANGEPANEL" blockxpos="25%" blockypos="0" blockbackground="FF9900" openbioblock="createbiopagetwo"/>
<create class="basicblock" blockname="yellowpanel" blockalias="YELLOWPANEL" blockxpos="50%" blockypos="0" blockbackground="FFFF00" openbioblock="createbiopagethree"/>
<create class="basicblock" blockname="greenpanel" blockalias="GREENPANEL" blockxpos="75%" blockypos="0" blockbackground="339900" openbioblock="createbiopagefour"/>
<create class="basicblock" blockname="bluepanel" blockalias="BLUEPANEL" blockxpos="0%" blockypos="33.4%" blockbackground="0000FF" openbioblock="createbiopagefive"/>
<create class="basicblock" blockname="indigopanel" blockalias="INDIGOPANEL" blockxpos="75%" blockypos="33.4%" blockbackground="CC33FF" openbioblock="createbiopagesix"/>
<create class="basicblock" blockname="violetpanel" blockalias="VIOLETPANEL" blockxpos="0%" blockypos="66.66%" blockbackground="990099" openbioblock="createbiopageseven"/>
<create class="basicblock" blockname="whitepanel" blockalias="WHITEPANEL" blockxpos="25%" blockypos="66.66%" blockbackground="FFFFFF" openbioblock="createbiopageeight"/>
<create class="basicblock" blockname="graypanel" blockalias="GRAYPANEL" blockxpos="50%" blockypos="66.66%" blockbackground="999999" openbioblock="createbiopagenine"/>
<create class="basicblock" blockname="blackpanel" blockalias="BLACKPANEL" blockxpos="75%" blockypos="66.66%" blockbackground="000000" openbioblock="createbiopageten"/>
</sync>
</action>

<action name="deletehome">
<delete class="basicblock" target="HOME"/>
</action>
<action name="createbiopageone">
<play action="deletehome"/>
<create class="basicbio" biobio="bioblockone" bioalias="BIOBLOCKONE" biovideo="biovideoone" biovideoalias="BIOVIDEOONE" bioimage="bioimageone" bioimagealias="BIOIMAGEONE" target="BIOPAGEPANEL"/>
</action>
<action name="createbiopagetwo">
<play action="deletehome"/>
<create class="basicbio" biobio="bioblocktwo" bioalias="BIOBLOCKTWO" biovideo="biovideotwo" biovideoalias="BIOVIDEOTWO" bioimage="bioimagetwo" bioimagealias="BIOIMAGETWO" target="BIOPAGEPANEL"/>
</action>
<action name="createbiopagethree">
<play action="deletehome"/>
<create class="basicbio" biobio="bioblockthree" bioalias="BIOBLOCKTHREE" biovideo="biovideothree" biovideoalias="BIOVIDEOTHREE" bioimage="bioimagethree" bioimagealias="BIOIMAGETHREE" target="BIOPAGEPANEL"/>
</action>
<action name="createbiopagefour">
<play action="deletehome"/>
<create class="basicbio" biobio="bioblockfour" bioalias="BIOBLOCKFOUR" biovideo="biovideofour" biovideoalias="BIOVIDEOFOUR" bioimage="bioimagefour" bioimagealias="BIOIMAGEFOUR" target="BIOPAGEPANEL"/>
</action>
<action name="createbiopagefive">
<play action="deletehome"/>
<create class="basicbio" biobio="bioblockfive" bioalias="BIOBLOCKFIVE" biovideo="biovideofive" biovideoalias="BIOVIDEOFIVE" bioimage="bioimagefive" bioimagealias="BIOIMAGEFIVE" target="BIOPAGEPANEL"/>
</action>
<action name="createbiopagesix">
<play action="deletehome"/>
<create class="basicbio" biobio="bioblocksix" bioalias="BIOBLOCKSIX" biovideo="biovideosix" biovideoalias="BIOVIDEOSIX" bioimage="bioimagesix" bioimagealias="BIOIMAGESIX" target="BIOPAGEPANEL"/>
</action>
<action name="createbiopageseven">
<play action="deletehome"/>
<create class="basicbio" biobio="bioblockseven" bioalias="BIOBLOCKSEVEN" biovideo="biovideoseven" biovideoalias="BIOVIDEOSEVEN" bioimage="bioimageseven" bioimagealias="BIOIMAGESEVEN" target="BIOPAGEPANEL"/>
</action>
<action name="createbiopageeight">
<play action="deletehome"/>
<create class="basicbio" biobio="bioblockeight" bioalias="BIOBLOCKEIGHT" biovideo="biovideoeight" biovideoalias="BIOVIDEOEIGHT" bioimage="bioimageeight" bioimagealias="BIOIMAGEEIGHT" target="BIOPAGEPANEL"/>
</action>
<action name="createbiopagenine">
<play action="deletehome"/>
<create class="basicbio" biobio="bioblocknine" bioalias="BIOBLOCKNINE" biovideo="biovideonine" biovideoalias="BIOVIDEONINE" bioimage="bioimagenine" bioimagealias="BIOIMAGENINE" target="BIOPAGEPANEL"/>
</action>
<action name="createbiopageten">
<play action="deletehome"/>
<create class="basicbio" biobio="bioblockten" bioalias="BIOBLOCKTEN" biovideo="biovideoten" biovideoalias="BIOVIDEOTEN" bioimage="bioimageten" bioimagealias="BIOIMAGETEN" target="BIOPAGEPANEL"/>
</action>
<action name="deletetest">
<delete class="basicbio" target="BIOPAGEPANEL"/>
<play action="createhome"/>
<set tofront="yes" target="HOME"/>
</action>
</actions>
</wire>
it looks like a pesky typo. You have onit="yes", which should be oninit="yes"
Thanks Ian, though now I feel really stupid.