+1
Fixed

Failed to build with fail message: failed_xcode_build

Ahmet Sülek 8 years ago updated by icahill (Administrator) 8 years ago 11
Hey,

I created an app using the wire editor. I can successfully preview it using Conduit. Now I'm trying to get an IPA file, first I had an error:

failed_openssl_p12_to_pem but I think I worked around this problem, because now I'm having failed_xcode_build error message.

Any ideas?
Ahmet,

Glad to see you are working with the Studio.

There are a couple of things you can try to alleviate that error. First of all, have you read through our tutorial on Cert creation? Apple doesn't make the process super easy, but we try to make it easy to understand.

Tutorial: http://content.rarewire.com/wordpress...

One of the main things we see with this error is a user attempts to recreate a p12 after the first try fails, but does not go into the Keys category and remove the key they used. This causes the p12 to store 2 keys, which can cause this error.
I think the solution that you address is for the error message: 'failed_openssl_p12_to_pem'

__________

The error message now I'm having is 'failed_xcode_build'

I followed the tutorial, sharing these tutorials is very thoughtful of you and thank you for the fast reply :)
If you are still having issues, make sure that you App ID is correct in the Studio, no wildcards are allowed on our side. Also make sure the provisioning profile you are using matches the cert you created.

Can you tell me your App ID from the browser address bar? usually a 3 or 4 digit number. I can look it up and see if you have extra provisions on our server which could have been caused by multiple keys.
Now I updated my Apple App ID to wildcard, but it failed again.

My RareWire App ID is 598.
That was a typo, NO wildcards are allowed when you add a bundle ID to the studio.

I will take a look at your App ID and see if you have some extra builds clogging the provisioner.
If we are sure that it's because of the provisioning profiles and certificates I can share the Apple Developer credentials with you via email.
We are actually just about to do a webinar about this very topic, if you want to log in and check it out.

http://anymeeting.com/RareWire1

If this doesn't help then I would be happy to take your credentials and check it out.

Thanks
Now I created a new app and followed the instructions on your webinar but it failed again with the same error message.

I think I produce a wrong .p12 file. I'm a member of a development team and we already have a distribution certificate for our company. So I didn't need to create and upload a CSR.

So I was putting the .p12 file that I produced from my development certificate. Obviously that was a mistake: using the company's distribution provisioning profile and my development certificate.

So that now I don't have the private key for our company's distribution certificate. What shall I do?
According to here:

http://forums.adobe.com/message/42119...

I must find that private key. Now I'm looking for it. I'll update the topic accordingly.
My issue is resolved. I just got the correct private key - certificate pair to create .p12 files. Hope the messages will help for the others. Now I have another issue and I'm opening a new topic for that :)
wonderful! Thank you for posing this issue in the community for others to see!